The Talking Machine Forum — For All Antique Phonographs & Recordings

It is currently Tue Feb 19, 2019 7:28 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Columbia Grafonola Speed Control Set Up Question
PostPosted: Fri Feb 08, 2019 4:53 pm 
Offline
Victor III
Joined: Wed Aug 01, 2012 8:43 pm
Posts: 832
Location: Port Huron, MI
This was a bit of a junker and I am not sure if something is missing or not. Is there supposed to be a spring or something on the shaft for the speed control lever? I have attached two photos: One showing the lever in question from the top and one from the underside. My screwdriver is pointing to the shaft I am wondering about.
Thanks in advance for any help!
Dave D


Attachments:
IMG_0089.JPG
IMG_0089.JPG [ 2.73 MiB | Viewed 156 times ]
IMG_0090.JPG
IMG_0090.JPG [ 3.61 MiB | Viewed 156 times ]
Top
 Profile  
 
 Post subject: Re: Columbia Grafonola Speed Control Set Up Question
PostPosted: Sat Feb 09, 2019 6:58 pm 
Offline
Victor III
Joined: Wed Aug 01, 2012 8:43 pm
Posts: 832
Location: Port Huron, MI
I took a chance on my own intuition and installed a spring under this lever. It works great and I discovered that Menard's has a nice selection of springs.
Dave D


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Americanized by Maël Soucaze.