The Talking Machine Forum — For All Antique Phonographs & Recordings

It is currently Wed Dec 19, 2018 9:46 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Columbia motor brake problem
PostPosted: Wed Sep 26, 2018 4:34 pm 
Online
Victor IV
Buyer of broken things
Joined: Sat Feb 11, 2012 4:10 pm
Posts: 1021
Location: Alston, UK
I've got a problem with my columbia AT motor, it's running fine now, just not stopping.
When I try to engage the brake it doesn't reach far enough along the springed section it seems and pings back, I'm a bit stuck for figuring out how to fix it

Attachment:
DSC01973.JPG
DSC01973.JPG [ 5.65 MiB | Viewed 244 times ]


Top
 Profile  
 
 Post subject: Re: Columbia motor brake problem
PostPosted: Wed Sep 26, 2018 8:00 pm 
Offline
Victor VI
Joined: Tue Mar 23, 2010 7:00 pm
Posts: 3443
Location: Western, WA State
That is common with Columbia cylinder motors. You'll have to bend or tweak the plate so the lever engages. Do this very carefully so the plate doesn't brake off.
Harvey Kravitz


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot], Dave D, Wes K and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Americanized by Maël Soucaze.